System requirements

From Angry Birds Evolution Wiki
Revision as of 16:00, 24 May 2017 by Tagaziel (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Angry Birds Evolution requires:

  • Android 5.0 and up
  • iOS 8.0 or later. Compatible with iPhone, iPad and iPod touch.