System requirements

From Angry Birds Evolution Wiki
Jump to: navigation, search

Angry Birds Evolution requires:

  • Android 5.0 and up
  • iOS 8.0 or later. Compatible with iPhone, iPad and iPod touch.